add fonts to AppIma...
Clear all

add fonts to AppImage, trouble recreating AppImage

1 Posts
2 Users
Topic starter

I wanted to add fonts for Titler effect, for the titles. As I use the Cinelerra AppImage, it was great to see the workaround for adding fonts detailed in the manual.


and here 


When I went to re-compress or re-create the AppImage after adding several TTF into /squashfs-root/usr/bin/plugins/fonts, the commandline

linuxdeploy-x86_64.AppImage --appdir squashfs-root --output appimage

failed to create a new AppImage. Many warnings but no result. The messages are at pastebin for a short time.

As a workaround, I can see that the expanded or uncompressed AppImage can be run as is. I have not tried this yet. So I mention this here simply as an observation. In the next days I will hope to run the expanded AppImage as is, and be able to use the added TTF.  I will report back on that success.

1 Answer


I looked at your pastebin but do not see the problem but since I have never actually tried this method that is not too surprising.  But at least 2 other people have successfully done so.  If I find the time today, I will test it myself.

However, with the work it entails and your obvious skills, I do wonder if you would not be better off just to do a single user build as described here:

and then add your desired fonts.  Quite a few users have been surprised at how easy it is to do the build themselves and it can provide access to graphic hardware that helps when the CPU is overtaxed and you need better performance.  In addition, I sometimes wonder, but have not proven, that compiling on your system might provide some minor speed improvements.